[SDL2.0.7] - SDL_WINDOW_FULLSCREEN_DESKTOP Fails On KDE Linux?

Hi,

The following code works 100% on Windows 10, but fails on KDE Linux(Manjaro KDE 64Bit):
(Running SDL 2.0.7 on Linux & Windows 10)

Any ideas on how to fix this?
Screenshot of issue

Jesse

        else if (interface->ArrowSetArrowSelectedByPlayer == 2)
        {
            visuals->FullScreenMode = !visuals->FullScreenMode;

            if (visuals->FullScreenMode == false)  SDL_SetWindowFullscreen(visuals->Window, 0);
            else if (visuals->FullScreenMode == true)  SDL_SetWindowFullscreen(visuals->Window, SDL_WINDOW_FULLSCREEN_DESKTOP);

            visuals->ClearTextCache();
            ScreenIsDirty = true;
        }
        else if (interface->ArrowSetArrowSelectedByPlayer == 2.5)
        {
            visuals->FullScreenMode = !visuals->FullScreenMode;

            if (visuals->FullScreenMode == false)  SDL_SetWindowFullscreen(visuals->Window, 0);
            else if (visuals->FullScreenMode == true)  SDL_SetWindowFullscreen(visuals->Window, SDL_WINDOW_FULLSCREEN_DESKTOP);

            visuals->ClearTextCache();
            ScreenIsDirty = true;
        }

Well, ok…

The game engine’s GUI button system still works after the “SDL_WINDOW_FULLSCREEN_DESKTOP”.
I can click on where the button should be and then the game recovers its display.

Not sure what the issue is though…
Using original SDL 2.0.4 did not have this issue on KDE Linux.
(running current SDL 2.0.7 on both KDE Linux and Windows 10)

Any suggestions would be appreciated…
…did not sleep so I guess I will hit this issue with a big hammer when I wake up, thanks!

Jesse

Ok, I think it’s fixed…
…was an issue with the game and not KDE + SDL2…
…will try to get this update done before the end of this year.
Thanks!

Jesse

Still happening :frowning:

There is a KDE setting that allows applications to block compositing.
The above option is ON by default.
If I turn off the above option then “SDL_WINDOW_FULLSCREEN_DESKTOP” works properly on KDE Linux.

Is there any way to tell SDL2 NOT to block compositing??

Thanks!

Jesse