sdl2-compat: README: Don't recommend installing libsdl3-3.0-0, which won't exist

From 0f6cb302be6d87035e884c2933ebaf16cca53d7f Mon Sep 17 00:00:00 2001
From: Simon McVittie <[EMAIL REDACTED]>
Date: Thu, 4 Jan 2024 17:43:20 +0000
Subject: [PATCH] README: Don't recommend installing libsdl3-3.0-0, which won't
 exist
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

The SONAME of SDL 3 is libSDL3.so.0, so its binary package name in
Debian/Ubuntu will be libsdl3-0 as per Debian Policy §8.1 (SDL 2 had a
redundant -2.0 in its SONAME, but we dropped that in the SDL 3 branch).

But we don't need to use that name explicitly in any case, because
libsdl3-dev depends on the shared library and will pull it in.

Signed-off-by: Simon McVittie <smcv@debian.org>
---
 README.md | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/README.md b/README.md
index e6bed2e..8f8ffe0 100644
--- a/README.md
+++ b/README.md
@@ -57,7 +57,7 @@ you might need to do (!!! FIXME: this won't work until SDL3 is further in
 development!) ...
 
 ```bash
-sudo apt-get install build-essential cmake libsdl3-3.0-0 libsdl3-dev libgl-dev
+sudo apt-get install build-essential cmake libsdl3-dev libgl-dev

Now just point CMake at sdl2-compat’s directory. Here’s a command-line