Smpeg for os x (to whomever is in charge of maintaining smpeg?)

I’ve tried compiling SMPEG for OS X and here’s the few changes that
would be necessary (as far as i can tell) for a successful
"./configure" and “make all”:

#1) Using ‘g++’ for cpp code

There seems to be 3-4 places, were ‘gcc’ is launched for compiling
something that obviously likes to be C++ (it complains about missing
’new’, ‘delete’, ‘new[]’ and ‘delete[]’.

I replaced the ‘gcc’ in those commands (on command line) by ‘g++’ and
got always one file further…

This was one of the commands:
gcc -g -O2 -I/usr/local/include/SDL -D_THREAD_SAFE -DTHREADED_AUDIO
-I/sw/include/gtk-1.2 -I/sw/include/glib-1.2 -I/sw/lib/glib/include
-I/usr/X11R6/include -DNDEBUG -I… -DNOCONTROLS -I. -I./audio -I./video
-o gtv gtv.o -L/sw/lib -L/usr/X11R6/lib -lgtk -lgdk -lgmodule -lglib
-ldl -lintl -lXext -lX11 -lm .libs/libsmpeg.a -L/usr/local/lib
-lSDLmain -lSDL -lm -lSDLmain -lSDL -lm -lSDLmain -lSDL -lm
-L/usr/local/lib -lSDLmain -lSDL -framework Cocoa -framework OpenGL

#2) No ‘malloc.h’

Made a short proxy to ‘memory.h’ instead of that, and it worked:

gcc -DPACKAGE=\"smpeg\" -DVERSION=\"0.4.4\" -Dsocklen_t=int  -I. -I.   
-g -O2 -I/usr/local/include/SDL -D_THREAD_SAFE -DTHREADED_AUDIO 

-I/sw/include/gtk-1.2 -I/sw/include/glib-1.2 -I/sw/lib/glib/include
-I/usr/X11R6/include -DNDEBUG -I… -DNOCONTROLS -I. -I./audio -I./video
-c glmovie-tile.c
glmovie-tile.c:19: header file ‘malloc.h’ not found

That’s all!