Strange behavior (now is C++ topic)

Hi Jimmy,

Your message came in attachment to me, but I saw it thanks to the subject.
So… yes… I’m checking returns from all SDL functions. Even, when I run
the compiled debug version outside VS.NET IDE, it runs good.

Today I take a deep loop in my code, using, comment-build-try test. I note
that this is not a problem with SDL. It’s something with memory allocation.
I’m creating C++ classes to generate 3D meshes from 4 vertexes and morph
them.

I created some simple classes like a class for vertexes, a class for
vectors, a class for line segments, and the last one, a class for the grid
itselfes. The grid class have an array pointer for vertexes, an array
pointer for normal vectors and an array pointer for the last morphing
position of each vertex.

I didn’t understand why inside VS.NET IDE I’m getting errors of memory
allocation instancing such class that does not use too much memory. I’ve
worked with 20x20 mesh grids and wven with 5x5 mesh grids I’ve got problem.

I know this is now off-topic, but this can be good for everyone on this list
that uses VS.NET with SDL and is working the same way as I, creating C++
classes to build OpenGL programs.

Thanks in advance,

Herbert> ----- Original Message -----

From: jimmy@jimmysworld.org (Jimmy)
To: “SDL Mailing List”
Sent: Friday, December 13, 2002 7:31 PM
Subject: Re: [SDL] Strange behavior