Symbol lookup error

Hello everyone,

i havent touched a little game source for a while. Now if i try to compiles and run with code:blocks
i get the error in the title: Symbol lookup error: /lib/x86_64-linux-gnu/ undefined symbol: SDL_RWseek.

It seems that some macro like SDL_RWseek have been converted into functions.

How can i solve this problem?
I’m using ubuntu 20.10
This are the library version i have:
ii libsdl2-2.0-0:amd64 2.0.12+dfsg1-4 amd64
ii libsdl2-dev:amd64 2.0.12+dfsg1-4 amd64
ii libsdl2-image-2.0-0:amd64 2.0.5+dfsg1-2 amd64
ii libsdl2-image-dev:amd64 2.0.5+dfsg1-2 amd64
ii libsdl2-mixer-2.0-0:amd64 2.0.4+dfsg1-2build1 amd64
ii libsdl2-ttf-2.0-0:amd64 2.0.15+dfsg1-1 amd64
ii libsdl2-ttf-dev:amd64 2.0.15+dfsg1-1 amd64

Kind regards

Anyone on this?

The code worked last time, but now, after many months, doesn’t work anymore.
Could someone give me an hint to solve?

Kind regards

As you said, the SDL_RW* macros have been turned into functions.
Those functions should be in recent versions of - is it possible that your game doesn’t actually use the from libsdl2-2.0-0:amd64 2.0.12+dfsg1-4 amd64 but and older version that’s still somewhere else on the system?
ldd YourGame should tell you which libs (incl. paths) it will use at runtime

I installed again SDL2 and SDL2 image. Same result.
Do you think i should delete all related to SDL2 and SDL2_image with purge?

Thank you very much.
Kind regards

No, I think you should use ldd YourGame to find out which is used.
Maybe you still have one in /usr/local/lib/ or some other directory from a “manual” installation (maybe from compiling an old version of SDL yourself).

Only if you can rule that out it makes sense to investigate whether the distribution packages are somehow broken.