Unable to build SDL_image


#1

Hi all! I’m trying to build the latest SDL_image from mercurial and it seems like I’m failing to do something correctly. For starters when I first clone the repo, I run configure and try to run make; It tells me that I need automake 1.14 (automake 1.15 is already installed) so I run autogen.sh, go through the same steps. When this process exits I get this message: libtool: link: gcc -I/usr/include/libpng16 -g -O2 -D_REENTRANT -I/usr/include/SDL2 -o .libs/showimage showimage.o ./.libs/libSDL2_image.so -lSDL2 -Wl,-rpath -Wl,/usr/local/lib
./.libs/libSDL2_image.so: undefined reference to `SDL_LoadFile_RW’
collect2: error: ld returned 1 exit status
Makefile:549: recipe for target ‘showimage’ failed
make: *** [showimage] Error 1

So I did also compile and install the latest SDL2 from mercurial which happens to be in /usr/local/lib

Anyone have a clue as to why I’m getting this error? I was able to do this with a much earlier version of SDL2.

Thanks!


#2

Sorry, SDL_image needs a newer version of SDL, and you have a system development library installed.

The requirement check is updated for the next SDL_image release, and you should be able to just remove libsdl2-dev in the meantime.