Upgrading 1.2.6 to 1.2.7

Hi guys,

I’m considering upgrading my copy of SDL to 1.2.7 for projects already
out there (http://www.MysteryStudio.com). I have kept 1.2.6 until now
because it’s stable enough for the games to be acceptably successful.

Is there any caveat, any change to be made to code that uses 1.2.6 when
upgrading to 1.2.7? Are there any known bugs in 1.2.7 that I should be
aware of?

Note that this question applies to the Windows, Mac and Linux builds.

Thanks in advance,

--Gabriel

i haven’t encountered any bugs when switching the jnrdev examples from
1.2.6 to 1.2.7
only using a 1.2.6 dll with code compiled for 1.2.7 gave wrong
colorkeying :slight_smile:
i only run on windows though.

Gabriel Gambetta wrote:> Hi guys,

I’m considering upgrading my copy of SDL to 1.2.7 for projects already
out there (http://www.MysteryStudio.com). I have kept 1.2.6 until now
because it’s stable enough for the games to be acceptably successful.

Is there any caveat, any change to be made to code that uses 1.2.6 when
upgrading to 1.2.7? Are there any known bugs in 1.2.7 that I should be
aware of?

Note that this question applies to the Windows, Mac and Linux builds.

Thanks in advance,

–Gabriel


SDL mailing list
SDL at libsdl.org
http://www.libsdl.org/mailman/listinfo/sdl

'lo Gabriel,On 09/07/2004, Gabriel Gambetta, you wrote:

Is there any caveat, any change to be made to code that uses 1.2.6
when upgrading to 1.2.7?

As far as I’m concerned, simply replacing the 1.2.6 DLL with the 1.2.7
one worked for my Windows OpenGL game. I didn’t update the includes.


Please remove “.ARGL.invalid” from my email when replying.
Incoming HTML mails are automatically deleted.