XCode 10 lengthy black screen at startup and in fullscreen?

I’m attempting to build an SDL project of mine in XCode 10.

On startup I get a black window for about the first 30 seconds after starting the application. Otherwise it is running (I can hear sound effects responding to input, etc.) but it’s mysteriously black for a long while.

When switched to fullscreen mode, the screen is permanently black. Similarly the game is still running, just with a black screen.

Has anyone else encountered this problem? Everything is fine in XCode 9, and was fine in XCode 8 previously, but it seems that XCode 8 won’t run on Mojave.

This is with SDL 2.0.7 and SDL 2.0.8. (Haven’t tried other versions.)

Additionally, I was unable to use configure with XCode10, though it worked with XCode9. I received an error of “C compiler cannot create executables”. I got around this by building via the XCode project, but thought it might be worth asking about in case it’s also an issue others are having.

Use the tip of SDL2 (newest mercurial) or wait a little bit for 2.0.9. It has been fixed there.

More like worked around. Apparently Mojave+XCode10+OpenGL is buggy as hell.

Thanks for confirming that it’s a known issue.