Announcement : SDL 2.0.8 driver for AGAR 1.5.0

For anyone that is interested.

I have finished writing a SDL 2.0.8 driver (renderer only, no GL) for AGAR 1.5.0 (GUI Forms/Menuing).

The driver has successfully completed the agartest validation suite.



1 Like

This looks great!

Are those “native” windows (one SDL_Window per Window) or AGAR-Windows within the same SDL_Window?

Native windows. I used AGARs MultiWindow driver because I knew SDL2 does support multi windows!

1 Like

1 Like

I am developing a database with SDL2 and I would like to try using the AGAR GUI. How can I get the libraries you have written or the code sources to compile.
I use a Mac with Xcode or windows with VS2015
Sorry, but I’m not very practical about using internet forums and to write in English I use a translator.
Thank you very much.

You can find instructions for building the SDL2 drivers for AGAR at this location:

The instructions are for building OVCC (which you you will not require).

However the instructions for building the SDL2 AGAR are also described there.

Just stop when you reach the instruction for cloning OVCC.

The instructions are only for Mingw and Linux but I have personally tried building on Mac and there were no issues Just follow the Linux instructions as a guide.

Thank you for the link.
I did a lot of testing but I got nothing.
I use the Mac with Catilina and SDL2 is installed as SDL2.framework
in the /Library/Frameworks directory ( not as static or dynamic libraries)
I have an agar directory with include files in /usr/local/include/agar.
The freetype library is installed.
The latest version of libtool as glibtool is installed in /usr/local/bin.
1^ test

  1. I downloaded the agar sources and made an AGAR directory on the desktop with agar / dir_of_sources.
    I downloaded from OVCC link the sources of additional patches and I copied them to their respective folders.
    I have modified the read and write permissions of the configure file and
    I made the configuration as:
    ./configure --with-sdl2 --without-sdl --with-libtool=/usr/bin/libtool

… (last part)
checking for the select() interface…yes
checking for the glob() function…yes
checking for the getopt() function…yes
checking for the execvp() function…yes
checking for clock_gettime() interface (w/o -lrt)…yes
checking for winmm time interface…no
checking for the nanosleep() function…yes
checking for the kqueue() mechanism…yes
checking for the Linux timerfd interface…no
checking for the Windows CSIDL system…no
checking for the Xbox XDK…no
checking for SDL2…framework…yes (2.0.8)
checking whether SDL2 works…no
checking whether SDL2 works (with X11 libs)…no

  • –with-sdl2 was requested, but the SDL2
  • library was not found.

With make depend all

armando-mc:agar Armando$ make depend all
==> core
cc -M -D_AGAR_CORE_INTERNAL -Ii386-apple-darwin19.0.0 variable.c config.c core.c error.c event.c object.c prop.c timeout.c class.c cpuinfo.c data_source.c load_string.c load_version.c vsnprintf.c vasprintf.c asprintf.c dir.c md5.c sha1.c rmd160.c file.c string.c dso.c tree.c time.c time_dummy.c db.c tbl.c getopt.c exec.c text.c user.c user_dummy.c
variable.c:26:10: fatal error: ‘agar/core/core.h’ file not found
#include <agar/core/core.h>
1 error generated.
config.c:32:10: fatal error: ‘agar/core/core.h’ file not found
#include <agar/core/core.h>
1 error generated.
core.c:30:10: fatal error: ‘agar/config/version.h’ file not found
#include <agar/config/version.h>
1 error generated.
error.c:30:10: fatal error: ‘agar/core/core.h’ file not found
#include <agar/core/core.h>
1 error generated.
event.c:31:10: fatal error: ‘agar/core/core.h’ file not found
#include <agar/core/core.h>
1 error generated.
object.c:30:10: fatal error: ‘agar/core/core.h’ file not found
#include <agar/core/core.h>
1 error generated.
prop.c:7:10: fatal error: ‘agar/core/core.h’ file not found
#include <agar/core/core.h>
1 error generated.
timeout.c:30:10: fatal error: ‘agar/core/core.h’ file not found
#include <agar/core/core.h>
1 error generated.
class.c:30:10: fatal error: ‘agar/core/core.h’ file not found
#include <agar/core/core.h>
1 error generated.
cpuinfo.c:30:10: fatal error: ‘agar/config/have_altivec.h’ file not found
#include <agar/config/have_altivec.h>

more equal errors on all other files.

2^ test
I used AGAR-SDL2-master with the files already updated but I had the same errors.

3^ test

I tried to compile the files with Xcode one by one starting from the “core” directory with the path to the include of /usr/local/include/agar set, but I think some definitions must be set for the precompiler because the compiler does not find some include files that exist in the path, furthermore externally declared definitions are sought as AG_ObjectClass, AG_Tbl, Ag_Namespace, AG_Mutex.

If you have any suggestions to give me I would be pleased, in order not to abandon my project of using AGAR.
Thank you very much.