Bad audio with smpeg 0.4.3 under NetBSD

I am using plaympeg, gtv and glmovie from smpeg 0.4.3 built from source
(and also tried NetBSD packaged version). This is under NetBSD 1.5.1_BETA

The audio is unintelligible. It buzzes, hisses, pops and is impossible to

I tried a few different mpg/mpeg files that I was told have working sound.

My sound works perfect for everything else (realplayer, Ogg Vorbis, splay
and others). I understand that the audio for smpeg uses a splay library. I
have not tried any other mpeg video applications to test the audio.

$ gtv NetBSD_on_DC.mpg
Warning: incorrect audio format

$ ./plaympeg ~/video/NetBSD_on_DC.mpg
Warning: incorrect audio format
NetBSD_on_DC.mpg: MPEG system stream (audio/video)
Video 320x240 resolution
Audio MPEG-1 Layer 2 192kbit/s 44100Hz stereo
Size: 4663300
Total time: 45.342967

$ plaympeg wedding320.mpg
Warning: incorrect audio format
wedding320.mpg: MPEG system stream (audio/video)
Video 320x240 resolution
Audio MPEG-2 Layer 3 32kbit/s 16000Hz stereo
Size: 4956160
Total time: 139.733333

Any ideas on how I can simply play just the audio from a mpg/mpeg movie
with another (non-SDL) audio tool, so I can test if the audio is okay?

Or does anyone know of an mpg/mpeg videos that include audio that I should

Any ideas on how I can troubleshoot or test the audio with smpeg or SDL?


Jeremy C. Reed

p.s. what’s the difference between the acronyms “mpg” and “mpeg”?