Checking whether SDL2.0.6 has vulkan support complied in

Does anyone know how to check if a SDL2 installation has vulkan support compiled in?

I have a similar problem to this Ubuntu 18.04 Launchpad issue that Ryan commented on.

I’ve been trying out the scout-beta of the steam runtime and the chroot build environment. This environment has SDL2.0.6 installed from the scout_beta steamrt repo.

At the moment I’m only using ‘SDL_Vulkan_GetInstanceExtensions’ which has been available since SDL2.0.6+.

When I use the steamrt beta chroot to build my game it builds no problem. But when I run it I get the SDL error: Vulkan support is either not configured in SDL or not available in video driver.

Now, I get the same error when I compile normally on Ubuntu 18.04 (with SDL2.0.8) because of the Launchpad issue above. I’ve got around this temporarily (at least until I eventually install Ubuntu 18.10 with the Vulkan support fix) by forcing gcc to use a version of SDL2.0.8 that I downloaded from libsdl and compiled with Vulkan support enabled. Then I use a launcher script to run my game using the libs from that same compiled SDL2 version.

So it looks like the steam runtime scout-beta chroot has the same SDL2.0.6 Vulkan not enabled problem as Ubuntu 18.04. Hence why I’d like to check within the chroot environment if Vulkan is actually enabled or not.

*edit: Typos

Using Ubuntu 18.10 and the --beta option for &, my Vulkanised SDL2 application will now successfully builds within the steam-runtime chroot using schroot --chroot steamrt_scout_beta_amd64 – make -f makefile.

I did have to enter the chroot environment and manually install libvulkan-dev though.

See closed Git Issue #105 for a step by step guide.