Code Blocks wizard broken: cannot create New SDL Project

I copied all my “known good” SDL files into c:\program files\codeblocks\mingw and it didn’t work. I put the include stuff in the include folder, and lib stuff in the lib folder and that doesn’t work either. It claims I’m missing SDLmain which is probably a .a file. It says that it tried to append a .a to the file name, in an attempt to find SDLmain.a but that didn’t work either. Someone from the SDL or Code Blocks community should fix this wizard. The most frustrating thing about c++ is not c++ but rather, setting up the development environment. Each time I try, I have numerous problems and it’s rare that I succeed in setting up SDL. Most times I fail and give up. This is really bad for productivity. I should be writing code but instead I’m struggling to configure SDL. I shouldn’t have to configure it in the first place. Is there an IDE that actually has a functional wizard that works every time?

PROBLEM SOLVED. Refer to post 5 on this thread: