[despammed] Re: debug problem

Yes I saw that NOPARACHUTE thingie recently but I’m currently using that and it doesn’t work either way.

The error I get when stepping with gdb is this:

Program received signal SIG32, Real-time event 32.
0x403f7479 in sigsuspend () from /lib/i686/libc.so.6

SIG32 seems to be related to pthreads, but my program doesn’t use any threads.
However I did find some stuff about that here:


I tried setting “handle SIG32 nostop” before running and now it works like a charm! Well atleast it doesn’t crash there anymore :slight_smile:


Krata wrote:>>Hi all

The thing is this, I’m devloping an OpenGL application under Linux
(with SDL of course), which works just fine. The poroblem is that when I
try to debug my application (with gdb) it always crashes on the
SDL_Init() call. Has anyone else had this happening?

Maybe you should enable SDL_INIT_NOPARACHUTE (i am not sure if this names
fits but it is something like this) if it doesn’t help it at least help’s
you to have core and i am sure that you will not expierience same problem
using gdb on core. (if you have some odd distribution take care of
ulimit -c if it is too small you will not have core)

SDL mailing list
SDL at libsdl.org

Filtered by despammed.com. Tracer: LAA276651033750616
Need cheap U.S. dialup but want to keep despamming your mail? Check out U.S. national dialup
access from $13.95 with Despammed filtration at http://www.myguard.net

SIG32 seems to be related to pthreads, but my program doesn’t use any threads.

You are not right. SDL => using threads.

seems like you are using HawkNL or something simiral next to SDL.
i want to use both myself. it would be nice if there was a HawkNL version
that was made compatible with SDL threads on both Linux and win32 ( so no
just setting HawkNL to use windows threads is no good cuz i want to
distribute for linux as well ). any idea’s ?

GreetZ :slight_smile: