[FEEDBACK] Lazyfoo Tutorial 52 Setting up SDL 2 on Windows Android Studio 3.0.1 : SDL

Hi,
I’m a new user of SDL2 and I’m going through Lazyfoo’s tutorial.

Tutorial 52 is somewhat outdated (Last Updated 6/10/19).

The latest Android Studio version is Artic Fox and the stable AndroidOS is at Pie.

I’ve tried to follow through the tutorial but there are multiple differences and I’m stuck at step 12 and 13.

I can find the Gradle version under Project Structure.

However, I can’t seem to Build the Project after that.

Then, on step 13, I can open the module but there’s no app to choose from.

How do I solve this?

Thank you for the help.

LAZYFOO TUTORIAL
12) If you try to hit Build → Make Project you’ll get the following error:

##### Minimum supported Gradle version is 4.1. Current version is 2.14.1.

This means our project is set to use the wrong version of Gradle. To fix this, set the Project window to project mode, “C:\androidprojects\SDL\gradle\wrapper\gradle-wrapper.properties” and change

##### distributionUrl=https://services.gradle.org/distributions/gradle-2.14.1-all.zip

to

##### distributionUrl=https://services.gradle.org/distributions/gradle-4.1-all.zip

Make project again (it may take a while to download Gradle 4.1) and you’ll get a new error:

##### cannot find symbol class Objects

LIST OF DIFFERENCES BETWEEN TUTORIAL AND ARCTIC FOX

  1. No SDK install location.
    c

  2. No option to custom install components

  3. When you import the file, there’s no import location to write to

  4. The tutorial references Jellybean (4.1) but AndroidOS is now on Pie.

  5. The dropdown for importing files have shifted

REFERENCES
https://lazyfoo.net/tutorials/SDL/52_hello_mobile/android_windows/index.php

I am in the process of migrating the build system for Android platform using Gradle +AGP + CMake. I use Kotlin DSL for the Gradle build script. Reusing the same main CMakeLists.txt for the building of the AAR. I could get it to open and build with AS Arctic Fox, as well as build with Gradle wrapper on CLI. Having said that, it is still work in progress. When it is ready I will submit it as PR.

I cannot help you on your issue though. I have not used it as reference.

That would be great
I’ve tried to create a CMake file for sdl_mixer, but no luck