Fullscreen,XFree3.3.5,DGA and SDL

I have a problem with running SDL(1.0.1) programs full screen,They just refuse to become full
screen even when I run them as root.I ran the test programs with the -fullscreen option but all of
them remained windowed.Same with the latest Maelstorm.I do have 640x480 modeline defined for 16bpp.

I can’t see where the problem is.It becomes more confusing since I have a vague memory of playing
Myth 2 demo(statically linked!!) in fullscreen a month back but now it also stays windowed.Of course
I upgraded my X server from 3.3.3(Redhat5.2) to 3.3.5(Redhat 6.1).Can there be a problem there?

I am able to run “State of Mind”(a demo program) fullscreen using DGA so there’s no problem with

Unrelated stuff:-
Is somebody telling the mpegtv people that SDL has gone to the next version?
Why is the default mouse cursor in SDL blunt?

Reporter (to Mahatma Gandhi): Mr Gandhi, what do you think of Western
Gandhi: I think it would be a good idea.

Bogus date in mail due to System clock problem.I was searching for my own mail which landed up at
the end of list sorted by date.SO if you missed …