Latest MacOSX Devel package fails to install


I just tried installing the LATEST MacOSX development package for
SDL 1.2.7, but it doesn’t work. At the end of the install, it says
there were errors during the installation script. Below is the log.

I tried installing it both before and after installing the
runtime library package.

My system is an iBook running MacOS X 10.2.4. I have the Apple
development stuff that came with it installed, including
ProjectBuilder, but not XCode.

Andrew Apted

SDL 1.2.7 Installation Log
Target Selection
_volumeAppeared: Adding volume OS X
_volumeAppeared: Adding volume Linux
deactivate: removing all cells from _volumeMatrix
Selected volume "OS X"
Mounted at: /
OpenFirmware: mac-io/ata-4 at 1f000/@0:3
Partition type: HFS+
Partition map: disk0s3
Partition: 3
Protocol: ATA
Media Type: Generic
Volume Size: 20002099200
Running post-install script
User is "aapted"
Moving SDL.framework to ~/Library/Frameworks
/Developer/Documentation/SDL/SDL.framework: exec: unknown option
/Developer/Documentation/SDL/SDL.framework: exec: unknown option
failed to resolve one of the sources (-120)
Precompiling Header
/Users/aapted/Library/Frameworks/SDL.framework/Headers/SDL.h: No such file or directory
no input files
Installing project stationary for Project Builder
Installing Man Pages
Rebuilding Apropos Database
/Developer/Documentation/SDL/Readme SDL Developer.txt
Permission denied
2004-04-13 19:54:35.745 open[479] No such file: /Users/aapted/Readme SDL Developer.txt
The post-install or upgrade script in SDL-devel failed.
Install Failed
Error detected
Name: NSGenericException
Reason: The post-install or upgrade script in SDL-devel failed. (code 1)