Odd unreliable touch input when mouse cursor is not displayed


I’m currently trying to get SDL to reliably work on an embedded system and have a few questions. At the moment it works perfectly fine, but I’m trying to remove the mouse cursor, which oddly causes the touch screen to only register approximately 40% of the presses. Other input is unaffected.

The system uses SDL 1.2 via fbcon and tslib, tslib is used through SDL and its event system. I am aware of SDL 2, but am not supposed to upgrade to it. The touch screen is a TSC200X, connected by I2C. After “SDL_Init(…);”, I disable the cursor with “SDL_ShowCursor(SDL_DISABLE);”, as documented here:

Using watch -n1 “cat /proc/interrupts”, I can see whenever a gpio interrupt is received from the touch screen. On not-registered presses, I don’t get any new interrupts either. I tried using a transparent or different cursor, but that works just as badly as when I completely disable the cursor. I tried enabling and disabling the cursor throughout using the application, but the touch input is unreliable only, when the cursor is disabled. I considered if this is a psychological effect of not having the same touch feedback or an issue of pressing hard enough, but after many tests with and without the cursor, I am very sure that this is not the problem.
Tslibs ts_test works perfectly fine.

Is there any reason why the SDL mouse cursor would have an effect on the touch input? What could be causing the issue?