Problems when running Maelstrom

Hello:

I have a Diamond Monster MX400 – when I try to run Maelstrom in Linux,
SDL gives me the following error:

[sfbosch at dsl-ch-l15-c80-n249-i136-cgy sfbosch]$ Maelstrom
SDL: Audio timeout - buggy audio driver? (disabled)

and Maelstrom hangs. What could be causing this?

-Stephen-

Hello:

I have a Diamond Monster MX400 – when I try to run Maelstrom in Linux,
SDL gives me the following error:

[sfbosch at dsl-ch-l15-c80-n249-i136-cgy sfbosch]$ Maelstrom
SDL: Audio timeout - buggy audio driver? (disabled)

and Maelstrom hangs. What could be causing this?

Check the FAQ:
http://www.libsdl.org/faq/FAQ-Linux.html#LINUX_13

See ya,
-Sam Lantinga, Lead Programmer, Loki Entertainment Software

Sam Lantinga wrote:

Check the FAQ:
http://www.libsdl.org/faq/FAQ-Linux.html#LINUX_13

Sorry - I didn’t realize this was an FAQ, though with the number of people
running Aureal boards I should have known better.

Have you had any luck with the July 30th version? Do I set the no_select
environment variable in rc.local?

Thanks,

-Stephen-

Sam Lantinga wrote:

Check the FAQ:
http://www.libsdl.org/faq/FAQ-Linux.html#LINUX_13

Have you had any luck with the July 30th version?

Yes, the latest CVS worked fine for me, but it crashed for someone else.
Your mileage may vary. :slight_smile:

Do I set the no_select environment variable in rc.local?

If you like - I usually set it in my .profile or whatever.

See ya!
-Sam Lantinga, Lead Programmer, Loki Entertainment Software

Hi, Sam & Co:

Have you had any luck with the July 30th version?

Yes, the latest CVS worked fine for me, but it crashed for someone else.
Your mileage may vary. :slight_smile:

AHHHHHHHHHH! I have tried two versions now - the July 30th version and the
"hot off the stamper" CVS version. They both compile fine, but there are
some problems:

My KDE sounds don’t work anymore
There is annoying static when I am playing wav or mp3 files from other
applications

and finally…

after about five minutes of operation the CVS driver goes BANANAS and starts
madly writing error messages to the system log, so much so that my hard disk
sounds like a flour mill…

sigh

Back to the 1.0.5 drivers. I don’t suppose this no_select variable is
implemented in that one, is it?

Not that all I do is play games, but… Maelstrom is really fun! Is there a
way to get it to run without sound (I know, it’s hilarious with sound, but
I’ll take what I can get until the sourceforge drivers are less buggy…)

Do I set the no_select environment variable in rc.local?

If you like - I usually set it in my .profile or whatever.

Duh… right. =)

-Stephen-

PS: Is Aureal really history for good now? Their website has been down for a
couple of months now… I know they were Chapter 11 but I thought they were
arranging a restructuring of some kind…