Problems with SDL-devel package for MacOS-X


yesterday, I tried to install the SDL-devel package to use with Project
Builder. I ran into problem at the end of the installation, so I
checked the history of this mailing list. I saw that several problems
were mentioned and resolved.

So it seems I ran into others… or that I didn’t saw all the mails
speaking of these problems.

The first problem is in the installation process. I’ve seen it
mentioned but it seems it’s not resolved.

The log file says :

Rebuilding Apropos Database
/Developer/Documentation/SDL/Readme SDL Developer.txt
Permission denied
2004-05-15 20:06:06.369 open[2705] No such file: /Users/mokona/Readme
SDL Developer.txt
The post-install or upgrade script in SDL-devel failed.

Indeed, if I ‘touch’ an empty Readme SDL Developer.txt in my home
directory and restart the installation, it’s ok. The real .txt file
(not the empty and just created one) can even be found in the
Documentation directory.

The second problem happened once the package was installed. No SDL
Projects appeared in Project Builder. After a little research (I’m new
to MacOS programming), I saw were all the files installed by this
packaged had “system” for owner with rights like -rwx------. Even the

After checking that other frameworks have rights like -rw-r–r--, I’ve
"chmod -R" all this. Then SDL Projects appeared in Project Builder.

After that, creating a new SDL Target made Project Builder crash…
still a reading right problem. Changed. Same for the documentation.

Now it works nicely, I’ve rebuild same of my SDL Linux sources with
Project Builder without problems.

I don’t know (yet) how packages are done, so I can’t change this myself.

For informations : system is MacOS 10.2 on a G3 iBook. Devel package
was downloaded yesterday from the SDL page.–
Sylvain Glaize