SDL 2.0.5 kernel error on init Controller or Joystick?

I’m getting a very odd error in SDL 2.0.5 when I include SDL_INIT_GAMECONTROLLER or SDL_INIT_JOYSTICK options in SDL_INIT(). It completely halts the program when debugging through each line when it hits SDL_INIT(). It’s worked fine on previous version (2.0.4 and lower).

Any idea?

In RaiseFailFastException () (C:\WINDOWS\SysWoW64\KernelBase.dll)

I’m getting exactly the same error at exactly the same place after installing 2.0.5 into an existing 2.0.4 project. Only happens when trying to debug. Using Eclipse, MiniGW, i686-w64-mingw32, Windows 10.

For me, it doesn’t matter what I pass into SDL_INIT(), it’ll always crash at the same place. The compiler fails to pinpoint where unless you step manually through every line until SDL_INIT().

I’ve copied the old 2.0.4 SDL2.dll file back in, and debugging works fine.

So, you can compile the 2.0.5 .libs in, and still use the 2.0.4 .dll to debug until the devs work out what’s going on :slight_smile:

Weird ok yea mine works using the 2.0.4 DLL as well - thanks! Only happens through Debug.

For the dev’s I’m using Codeblocks, i686-w64-mingw32, Win 10.

Hi Russell,


This fixes it, thank-you. I remember reading about this before, but couldn’t remember where or what exactly.


Please see this