SDL and Bloodshed Dev-C++ - Finaly solved my Problem

Hi all !

Finaly I solved the problem of using the bloodshed dev-c++ ide with SDL.
Here is finally what I did:

1.) Download the SDL binary release for windows.
2.) Extract it to a temporary folder
3.) Copy the /include and the /lib directory to your /dev-c++ directory
4.) Copy the SDL.dll (located in the /lib directory) to /windows/system
5.) Create a new “console” or empty project
6.) open the project options and :
a) add the line “-lmingw32 -lSDLmain -lSDL” to project linker options
(it is absolutly necessery to link in this order, it won’t work e.g.
if -lmingw32 is the last library to link !)
b) add the directory dev-c++\include\sdl\ to your extra include

Programs seem to compile o.k. now. :slight_smile: Maybe this could be added to the Win32
FAQ, while many open-source developers on windows use the bloodshed dev-c++
ide, while it is open-source itself.



P.S.: Does anyone have the precompiled binarys for SDL_ttf and SDL_image
ready for the mingw32 ? I didn’t make it to compile those myself.