SDL_Error could no be located in the dynamic link library

Return-Path: @Marek_Skorkowski
Message-ID: <41d8b512628e4 at>
MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-2
Content-Transfer-Encoding: 8bit
Content-Disposition: inline
X-Mailer: Interfejs WWW nowej poczty Wirtualnej Polski
X-User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020 Firefox/0.10.1
Organization: Nowa Poczta Wirtualnej Polski S.A.
X-WP-AV: skaner antywirusowy poczty Wirtualnej Polski S. A.
X-WP-SPAM: NO AS1=NO AS2=NO(0.504833) AS3=NO AS4=NO

Hello developers,

When I try to execute my program on Windows I get message: ‘The procedure entry point SDL_Error could not be located in the dynamic link library SDL.dll’ and program exits and if I start to debugg the program it works fine, until I try to close it, because I got then segmentation fault

I’m using Dev-C++ with SDL 1.2.4

This has been fixed with SDL 1.2.8
Make sure you edit SDL_audio.h and remove SDLCALL from the line that doesn’t
compile, due to a bug in gcc’s parser under Windows.

See ya!
-Sam Lantinga, Software Engineer, Blizzard Entertainment> Hello developers,

Thanks! I have updated SDL and now it works beatyfull :smiley:

On Linux Fedora Core 3 with gcc 3.4.2 and SDL 1.2.8 always when I execute program I get Segmentation fault. Gdb said 0x0804bd in close (). As far as I understand gdb a program crushes at line ‘if (SDL_Init (SDL_INIT_VIDEO) != 0)’

Answer for this is simpler. I have created global variable ‘close’ which is somehow interacting with SDL, and makes the segmentation fault.

Thanks to all who tried to figure this out.
Pami?taj o noworocznych ?yczeniach - zobacz gotowe tre?ci ?ycze?!