SDL issue when opening at 640x480 (Was Re: Tux Paint - Canvas Size)

Hi Doug, I’m forwarding this to the tuxmath list (you forgot the
"lists." after the “@” and before the “sourceforge”). I’m also Cc’ing the
SDL development mailing list.

This sounds like an SDL issue. Tux Paint can open at different screen sizes,
use either specific options, or it can ‘detect’ when given the "–native"
switch. It sounds like on Doug’s system, SDL is unable to open a screen
at 640x480, even with the ‘letterbox’ or ‘border’ effect that SDL typically

(Note: Doug’s system specs are in the quoted messages, below.)

Perhaps there’s an easy work-around at the SDL level, but I’m not familiar
with it.

Thanks and good luck!

-bill!On Sat, Mar 22, 2008 at 09:07:19AM -0400, Doug Steele wrote:


I have been playing with TuxMath and TuxPaint and have encountered a
problem with each that is similar to one I asked about in TuxPaint
concerning the ull-screen mode. I tried to send a bug msg to
tuxmath-devel at adn the msg bounced. I notice that you
are in the list of developers for TuxMath and TuxPaint, and hope you
can pass my concerns to the right person.

Here is the msg I sent:


These look like very useful program. I have found what looks like a
bug in each.

The TuxMath shortcut, “Tux of Math Command” installed to desktop
opens the windowed version, which works ok. Opening using the
shortcut “Tux Typing (Full Screen)” opens full screen and then
flashes a msg something to the effect “You have chosen a non-optimal
setting for your LCD screen…” and then the program quits. [1]

The TuxTyping shortcut “Tux Typing” opens full screen and flashes the
same error message about non-optimal screen settings and then quits.
[1] Opening TuxTyping using the shortcut Tux Typing (Windowed) opens
a small windowed version that behaves correctly.

These behaviors are the same as when I configured TuxPaint to be
full-screen, but did not set check the Video | Native check box (Use
native screen resolution in fullscreen mode) and had the window size
not manually set to my PC’s screen size.

Is there a means to configure either TuxMath or TuxTyping? If not,
then I would suggest that these full-screen behaviors are bugs. I
suspect the solution is to implement a feature that is equivalent to
TuxPaint with the Video | Native check box checked.

I am running Wndows XP Pro on a Dell Inspiron 8500, which has a 1920
x 1200 screen. The versions of TuxMath and TuxTyping I have installed are

Note [1]: Actually I found that it does not quit. It just minimizes
the program to the task bar. If I click on the taskbar icon, it
opens, gives the non-optimal screen settings msg and then minimizes
the program again. when I tried twice to start one of the programs, I
enede up with two minimized copies, which I could quit using the
Right-click Close Group command. If I opened only one copy of the
program, I got only one task-bar icon and found that the only way to
quit the program was with the Task Manager.


At 20:45 3/14/2008, you wrote: [with subject: Re: Tux Paint - Canvas Size]


New topic 2: When I tested ‘Tux Paint - Full Screen’ on my 1920 x
1200 monitor with the config tool window size of 1400 x 1050, Tux
Paint opened and presented a message that the window size was not
optimum and then went into the minimized mode.

That’s odd. Tux Paint itself doesn’t have any thing that would say it,
so it may have been Windows, or maybe your monitor itself…?

I was, then, not able
to quit Tux Paint by right-clicking – there was no menu that popped
up with the expected ‘Close’ entry. I had to use task Manager to
kill it. Since you put up the black panel that surrounds the Tux
Paint window, I am guessing that you have determined the monitor’s
screen size. Would it be possible, when starting in the full-screen
mode, to adjust Tux Paint’s window size to be the same as the
monitor’s screen size, overriding the info set by the config tool?

Yes, in fact. There’s a “native” option, available since version 0.9.17.
Tux Paint Config has a checkbox for it.


bill at

I can open using the windowed shortcut (with the -w switch) and get a
normal 640x48 window. My problem occurs when I try to open with the
full-screen shortcut (with the -f switch). TuxPain works fine windowed or
full screen, but it has a config program that lets me set the Native bit
that tells it to detect and use my screen size when opening full screen.
Since TuxPaint works correctly, I don’t think it is a graphics driver on
my PC. It seems like TuxMath and TuxTyping are not detecting my screen
size. If I don’t set the native bit in TuxPaint and try to open full
screen, I get the same behavior as I am describing for TuxMath and
TuxTyping. Is there a command line option for setting the native bit?

Doug, the only reason Tux Paint works is that it’s able to resize itself
to something other than 640x480. You said that Tux Paint did have that
issue, when you didn’t have the Native Screen Size setting checked.

The other apps insist on 640x480, and therefore that’s all they can do.

SDL on Windows can either use DirectX or WinDIB as a back-end.
Recently, they changed the default.

You can set it yourself, by following these instructions from the Tux Paint
site (this tells you how to run using WinDIB, versus DirectX, which was the
SDL default; eventually, Tux Paint overrode that setting internally, and
eventually the SDL folks changed the default to be WinDIB on their end).

Try using both “directx” and “windib” as the setting, and see if any
of the apps work with one or the other.

Good luck!On Sat, Mar 22, 2008 at 10:19:24PM +0000, Caroline Ford wrote:

bill at