SDL malfunction on Suse 9.2

Hi all,

I wanted to start Linux programming on Suse 9.2 to continue an existing
For this project I got the source and the executable, which runs fine.

The I tried to compile the source, but it failed due to missing SDL-devel.
I got the SDL source archiv (1.2.9) form, compiled and installed
it without visible errors.
After that, compiling was fine, but when starting I got only a black screen.
Thinking there may be a bug I analyzed the source and played with the
SDL-flags. The best combination of flags shows me the screen (depth: 8bit)
with a picture, but blitting the mouse pointer (application generated)
doesn’t work as expected, the restored background is always a black

I uninstalled the SDL 1.2.9 to get the original Suse 9.2 config, and the
original app runs fine again.

So it seems to be a problem with the version of SDL or with my Suse config.
The original Suse is deliverd with SDL 1.2.7-41, but there is no devel
packet, so I can’t compile.

Upgrading to 1.2.9 is good for compiling, but the app doesn’t run as

What did I wrong or how to solve the problem?

I also uninstalled all SDL stuff and only install the source archiv SDL
1.2.9, but still the same problem.

Christian Beer