SDL2 Library is not Detected - Wwise Cube Demo

Apparently this is plaguing many people, (Hopefully it’s not just me being an idiot).

I’m going through the Wwise Certification Tutorials, on Mac running Mojave 10.14.6.

When trying to launch the Cube Demo, I get an error message on the launch page that reads
“The SDL2 library is not detected.”
Which links me to a download for the libSDL2.framework.

After installing it multiple times to no avail I clicked the actual SDL alias file and and an error popped up saying that the “SDL has been damaged”

Apparently this is due to a bug that is affecting the Mac OS Mojave update (which isn’t even the newest update so you would assume all bugs would be fixed).

I haven’t been able to find any answers from SDL, or AudioKinetic, if anyone can help or link to any useful pages that would be great.

If you have xcode installed you might be able to try building the framework from the source and see if that one works. Alternatively if you have not already tried it you can try the framework from here and see if its any different.

In the source archive there is an Xcode/SDL folder with SDL.xcodeproj. By default you will get a DEBUG build. If you want a release build you can select manage schemes and “Edit” the framework build to be Release (or just pick edit scheme for the selected one, my screenshot shows the long way). The play button should build whatever you have selected.


Consult docs/ for some related information.

Think this might be helpful as I saw someone’s response on reddit and it really worked for me!

I put the file in “My username/Library/Frameworks”
But actually it should be put in “Macintosh HD/Library/Frameworks”