SDL2 still not able to install mixer under iOS

Thanks for the advice here (by rtrusseu, great thanks) ,I successfully do the TTF using the non-source version and TTF work.

Now trying mixer. Unfortunately trying both mixer source (with release…) and non-source (without the release), none work. The error message tbh is very strange:

/Users/kwccoin/Documents/Github/_SDL_loadlib/gof/SDL-release-2.30.3/include/SDL_log.h:355:100 Expected function body after function declarator

extern DECLSPEC void SDLCALL SDL_LogMessageV(int category,
SDL_LogPriority priority,

in file included from /Users/kwccoin/Documents/Github/_SDL_loadlib/gof/SDL_mixer-release-2.8.0/Xcode/iOS/SDL2.framework/Headers/SDL.h:49:
Somehow something is missing. Trying all sort of ways like adding header to both system and usual search. None work so far sadly.

Continue to search a way. Any help will be much appreciated.

Try both 2.7.2 source and non-source, not working still and same error message.

Outside xCode and run it via homebrew it works. Hence, it is all about configuration … as said, it is very hard on iOS environment.

Continue my struggle.

The message really not making any sense:

/Users/[user]/Documents/Github/_SDL_loadlib/gof/SDL-release-2.30.3/include/SDL_log.h:355:100 Expected function body after function declarator

in file included from /Users/[user]/Documents/Github/_SDL_loadlib/gof/SDL2_mixer-2.7.2/src/codecs/music_drflac.c:28:

in file included from /Users/[user]/Documents/Github/_SDL_loadlib/gof/SDL2_mixer-2.7.2/Xcode/iOS/SDL2.framework/Headers/SDL.h:49:

search and one can see .c is with .h files … hence still not sure how to proceed.

Getting the exact same thing here when trying to add mixer.

Edit: Actually, “Clean build folder” removed the issue.