SGE and SDL (c/c++ linking probs?)

This is in regards to the SDL add-on, SGE (which doesn’t happen to have
it’s own mailing list). I apologize if this is a bit off-topic for this
mailing list, but I wanted to see if anyone here could help.

I am having problems linking to SGE in my program. SGE is written in c++,
while my program is written in c.

I first tried just statically linking in all of the SGE “.o” files, like
it was described in SGE’s documentation for the version I had. Even
though the functions existed in those “.o”'s, it still told me during the
link phase “could not find function…blah”.

He recently updated it with a new version which created I
created the libSGE.a with ‘ar’ myself. I then tried to link against that,
still with no luck. Any suggestions would be greatly appreciated.

Here is the output from make:----------------------------------
gcc -o bin/sage -L/usr/X11R6/lib -L/home/hayward/sge991219b object_files/main.o object_files/player.o object_files/event.o object_files/graphics.o object_files/db.o object_files/font.o object_files/init.o object_files/utils.o object_files/alloc.o object_files/grid.o object_files/network.o object_files/netcmds.o object_files/path.o object_files/constants.o net/net.o net/unix/net_ux.o -g -Wall -lX11 -lSDL -lpthread -ldl -lSGE -lttf

and here is the resulting output: (all functions found in libSGE.* which
are used in my program are not resolved):

object_files/font.o: In function sage_init_fonts': /home/hayward/sage/SDLsage/font.c:16: undefined reference tosge_TTF_Init’
object_files/font.o: In function sage_load_font': /home/hayward/sage/SDLsage/font.c:26: undefined reference tosge_TTF_OpenFont’
/home/hayward/sage/SDLsage/font.c:29: undefined reference to
sge_TTF_OpenFont' object_files/font.o: In functionsage_draw_text’:
/home/hayward/sage/SDLsage/font.c:48: undefined reference to
collect2: ld returned 1 exit status
make: *** [bin/sage] Error 1