SIGSEGV after RedHat installation/up2date


I’m new to this list. May I introduce myself? I’m one developer of the EmuTOS
project, we develope a TOS clone for Atari ST series computers. Our Team works
close together with the developers of Aranym - or we overlap. Aranym is an
Atari Falcon emulator, which is based on SDL.

For my tests I need to have Aranym running. This worked quite well for a longer
time. A short time before christmas my harddisk did crash, I reinstalled

  • RedHat 7.0
  • SDL 1.2.3-1

and did an update of my system with RedHat’s up2date. Maybe, I got an update of
XFREE86… don’t know the version now - it may be the newest.

Everything is running fine, just if I want to start this Aranym emulator (which
compiles well with SDL), I get a SIGSEGV. I then tried some of the SDL demos,
which did work well, but when I tried to run Hexen, I got the same error.

Because I’m not familar with using debuggers, I just used strace to see, which
system calls may have failed. The last calls where 2 times mprotect() (don’t
have the actual trace here at work, but can send it later, if needed). The
complete end of the starce output were the same for Hexen and Aranym. So I
think, the problem may be in a library used by both. Because all other things
work well form me, iot could be, that it is a problem with libSDL.

Is this problem known - means, are there some incompatibilities with libSDL and
other libs, which I could test? Or can you point me somewhere, how I could go
on? What I could try? Unfortunately I’m not familar with debugging. Maybe, I
should start it now… What debuggers do you use?

Can I make libSDL have less features, so that I possibly can get around this
bug? Maybe, it asks for a joystick or what, and I have none?!?

Any help would be nice. And sorry, if my questions sound a bit newbie like - I
don’t have much experience here…–
Martin Doering