Textures crap in fullscreen in opengl in 1.2.15; not in 1.2.14

I am developing a game using SDL for input, windowing, non-hardware
texture handling and such, OpenGL for the actual drawing and bare
libpng for loading of PNG images.

I tried to update SDL from 1.2.14 to 1.2.15 and stumbled to a strange
problem on Windows: Fullscreen textures don’t work anymore. Whether I
toggle to fullscreen while running (with proper texture reloading and
stuff) or directly start in fullscreen. Both work in 1.2.14.

All textures always come up as completely white when rendered in
OpenGL, as if they were not loaded at all. I think I saw some
carbageish or warped textures at some point too but cannot reproduce

I can just swap the DLL for the game built with either 1.2.14 or
1.2.15, and get this behaviour based on the DLL version.

Everything works on Linux for me. Windows is XP running in VirtualBox.
I am using the official SDL-devel-1.2.15-mingw32.tar.gz (and .14)

I have been debugging the code and everything seems to work; the
SDL_Surface is fine if I write it to disk using SDL_SaveBMP just
before glTexImage2D. And OpenGL doesn’t seem to return an error.

Does anyone have any idea why this could be? I tried browsing the
commit logs but couldn’t really come up with anything.

// celeron55