! Troubles with Mouse without X!

Hi,
I developing a nice File manager using SDL. I like to use it without X but
if I try to run my application form bash, I receive:
Couldn inizialize SDL: Unable to open mouse.

Well.

I built my system from scratch (see Linux form scratch at LPD). In my /dev
directory I have only

bash-2.04# ls /dev/mouse -l
crw-rw-rw- 1 root sys 10, 3 May 9 09:46 /dev/atimouse
crw-rw-rw- 1 root sys 10, 4 May 9 09:46 /dev/jmouse
crw-rw-rw- 1 root sys 10, 0 May 9 09:46 /dev/logimouse
crw-rw-rw- 1 root sys 10, 2 May 9 09:46 /dev/msmouse
crw-rw-rw- 1 root sys 10, 1 Jun 7 16:15 /dev/psmouse

so you can see I have no /dev/mouse.

Under X my mouse works properly, and in XF86Config file I selected
/dev/psmouse.

So I made the link /dev/mouse to /dev/psmouse.

I tried to run my application but even if it started, the mouse didn,t work
good.

Any Ideas

Thanks a lot.

Fabio Giovagnini

Aurion S.R.L.

I built my system from scratch (see Linux form scratch at LPD). In my /dev
directory I have only

bash-2.04# ls /dev/mouse -l
crw-rw-rw- 1 root sys 10, 3 May 9 09:46 /dev/atimouse
crw-rw-rw- 1 root sys 10, 4 May 9 09:46 /dev/jmouse
crw-rw-rw- 1 root sys 10, 0 May 9 09:46 /dev/logimouse
crw-rw-rw- 1 root sys 10, 2 May 9 09:46 /dev/msmouse
crw-rw-rw- 1 root sys 10, 1 Jun 7 16:15 /dev/psmouse

So I made the link /dev/mouse to /dev/psmouse.

Actually, make a link from /dev/psaux to /dev/psmouse

See ya,
-Sam Lantinga, Lead Programmer, Loki Software, Inc.

thanks a lot. Now my mouse works fine.

“Fabio Giovagnini” ha scritto nel messaggio
news:9fo34g$7u2$1 at ftp.lokigames.com

Hi,
I developing a nice File manager using SDL. I like to use it without X but
if I try to run my application form bash, I receive:
Couldn inizialize SDL: Unable to open mouse.

Well.

I built my system from scratch (see Linux form scratch at LPD). In my /dev
directory I have only

bash-2.04# ls /dev/mouse -l
crw-rw-rw- 1 root sys 10, 3 May 9 09:46 /dev/atimouse
crw-rw-rw- 1 root sys 10, 4 May 9 09:46 /dev/jmouse
crw-rw-rw- 1 root sys 10, 0 May 9 09:46 /dev/logimouse
crw-rw-rw- 1 root sys 10, 2 May 9 09:46 /dev/msmouse
crw-rw-rw- 1 root sys 10, 1 Jun 7 16:15 /dev/psmouse

so you can see I have no /dev/mouse.

Under X my mouse works properly, and in XF86Config file I selected
/dev/psmouse.

So I made the link /dev/mouse to /dev/psmouse.

I tried to run my application but even if it started, the mouse didn,t
work> good.

Any Ideas

Thanks a lot.

Fabio Giovagnini

Aurion S.R.L.