Using SDL Under Cygwin

I am trying to use SDL-1.2.6 under Cygwin. I decompressed the source
and built it using configure; make; make install.

The first problem is with the paths. SDL put the headers in
/usr/local/include/SDL and the libraries in /usr/local/lib. They seem
to need to be in /usr/include and /usr/lib, respectively. I couldn’t
get gcc to find the headers normally until I dumped the .h files
straight into /usr/include. This should seem odd since the headers are
referenced as <SDL/SDL.h>, for example (the subdirectory is right in the

The second problem is I don’t seem to have OpenGL support. I am using
the testgl demo to get it working. I run configure in the test
directory and get this line:

checking for OpenGL support… no

It’s an ambiguous line, and I assume there’s a trick I need to do to
turn OpenGL support on. I tried initially building with
–enable-opengl, but that didn’t help any.

Oddly enough, I have the same problem with SDL under Linux on the same
computer. I am running a DRI server that has working OpenGL extensions
(or so glxinfo tells me), yet SDL doesn’t think I have OpenGL support.
I am frustrated.

I’m sorry to rely on you folks for technical support, but the tutorials
on how to get this working just don’t seem right (or have become
inconsistent). I have updated Cygwin in the last week, and it was all
that MinGW stuff that is now included.

Also, I am not on this list yet, so please make sure my email address is
in your responses. I’ll join the list if I can actually get this stuff