XCode templates and documentation missing

The runtime and development downloads in http://libsdl.org/download-2.0.php look different but point to the same DMG file.

After installing the downloaded framework there is no SDL template in Xcode.
(the DMG file contains nothing else)

According to here there should be:
http://www.meandmark.com/sdlopenglpart2.html
“At the download site you will see two types of libraries: runtime and development. You must download both libraries. The runtime library contains the SDL framework. The development libraries install documentation and SDL Xcode project templates on your computer.”

2 Likes

That info is extremely old and out of date.

For modern Xcode (latest public version is Xcode 11), just make a regular app. Then

  1. Rip out all the AppDelegate, ViewController, .storyboard/.xib files, that are put in there by the template
  2. Copy SDL2.framework to the same place as YourProject.xcodeproj
  3. Add SDL2.framework as a linked/embedded framework in your app’s build settings (go to the “General” tab, then down in the “Frameworks, Libraries, and Embedded Content” section hit the +, choose “Add Other” at the bottom of the window that comes up, select SDL2.framework). Xcode will automatically configure your project to copy it to your app’s bundle and code sign it.
  4. Make a file called main.c or main.cpp, put your main() function in it, and off you go.

It’s as if some strange disease is affecting the brains of the leaders in The Old Company, Even the food in the canteen has been affected. The list of ingredients makes no sense, it is nutritionally wrong and it smells really bad. I decide to leave and search for another place to work and eat, although I know that every other company is likely closed, and that even finding another place to eat will be hard.

After leaving camp I walk for a week with no food. I finally decide to try an old Keto restaurant that I used to know. The door is open and I go in. It smells like food and the lights are on. I enter and sit on a table, but no one comes. There are some menus laying around, with both familiar and new stuff. I wait for a few days, but still no one comes. A few other customers pass by but they quickly give up. I also give up and decide to go look for food somewhere else. In a desperate attempt I write some notes and leave them on the table. They ask, in several languages: “how can we have food in this restaurant? Are the things on the menu still available?”.

One week later, passing by, I think that I can hear some noise and I look inside. Someone has replied to one of my notes. I put it in my pocket and leave.

Only the next morning I will read it:
“This floor has not been in use for a long time, and the menu has long been deprecated. We still serve food, in the basement. The paper menus are not valid any more. The things you can order are written on one of the walls somewhere, in shinny black paint, it’s really easy to find. To get to the basement it is really easy: go to one of the toilets and remove all the furniture in it. There is a green closet n the wall, knock 3 times on the door and then make a pause and knock another 4. The door will open and you just have to go down the stairs, they’re a bit steep but its’s really easy. Remember to avoid the even numbered steps, they’re a bit broken”

I’m staying on a metal boat in the port of Amsterdam. There was a bit of a storm and some water got in the boat. An electrical plug got wet and it tripped the circuit breaker. I‘m also a bit wet, my shoulder is hurting, the heater is not working, and the battery on my computer is going down. It’s 7 am and I still have to wait for 3 hours for someone to arrive. I have my phone, but the craziness in the Old Company has somehow affected it, all its software feels a bit awkward and unreliable. Things like the spelling corrector insisting on correcting text that was actually correct really get on my nerves. It’s as if there is not a grown up in charge any more. It’s not that I don’t like children or old people, but they make funny choices sometimes. How everyone else pretends that everything is fine and puts up with everything that is happening is mind boggling. I can not sleep and have nothing else to do so I type this message on my phone. This last paragraph is actually literally true. Joaquim

the app that 15 years ago was SDL and now is iOS and I want to make SDL is in the app store. If someone wants to have a look:

…and sjr, thank you for your detailed reply.
Now I can continue with my plan: leave iOS + OpenGL and go SDL + Vulkan / Molten