Events dont fire? SDL_MULTIGESTURE + SDL_MOUSEWHEEL ... (OSX 10.14.6)

Does SDL_MOUSEWHEEL or SDL_MULTIGESTURE work for anyone using SDL 2.0.12.

It worked in SDL: 2.0.5 I updated to SDL 2.0.12.

Full disclosure, it hasn’t worked since like SDL: 2.0.8 or so maybe even SDL: 2.0.6 So I avoided updating SDL. Reverting to 2.0.5 fixed the issue. I have no idea what the problem is.

testgesture.c does nothing for me. its just a blank gray window.

Both are working for me with SDL 2.0.12 on Windows 10. On MacOS I’ve only got 2.0.10 so I can’t do the test.

Thanks. Are you an SDL dev? If not thanks for testing it lol.

if you are… there must be a way for you to test this?

Oh btw…

SDL 2.0.10 should display the same error for me. Can you test that on MacOSX?

SDL_MOUSEWHEEL events are firing normally for me in Mac OS High Sierra (I don’t have Mojave or Catalina to try, sorry).

What about pinch/rotate? Also works normally? Are you on a laptop or desktop?

I’m pretty sure I saw the same bug back on MacOSX El Capitan (10.11). So… I don’t think the OSX version is the problem. But both computers were Mac Laptops.

It’s a Mac Mini so no touchscreen or touchpad.

Thanks… ill ask again in a new topic :slight_smile: